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SpaceMaker® for Windows (Standard Edition) is the latest file search utility that identifies all duplicate 
files on your disk, displays them, and allows you to delete those you no longer need. You can also search 
for any file or files on your disk, such as *.BAK files, and remove them instantly to get more room for other
applications.

SpaceMaker Plus® for Windows (Enhanced Edition) is the enhancement to the SpaceMaker for 
Windows. It identifies duplicates, the oldest and the largest files, as well as it allows you to combine file 
searches across multiple drives and directories by utilizing File Manager`s drag and drop capabilities. The
Enhanced Edition is available to registered users for a small additional fee. 

SpaceMaker® for Windows and SpaceMaker Plus® for Windows are fully functional, powerful, safe, 
efficient, and easy to use programs. Features available in the SpaceMaker Plus are marked with a  
symbol throughout the help file.
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For information on how to use Help, press F1 or select the Using Help command under the Help menu.



New Features in Release 1.4 
This version of the program has been improved for speed and usability. Major features have been added 
along with some minor enhancements. The new features include:

- listing files by pathname 
- listing newest files 
- removing identical entries from the Browse Window 
- printing either entire list or a selection
- lists are printed with user-specified font and size
See also: Printing, Cleanup List



The Toolbar
The Toolbar is a row of buttons at the top of the main window which represent application commands. 
Clicking one of the buttons is a quick alternative to choosing a command from the menu. Buttons on the 
toolbar activate and deactivate according to the state of the application. Some buttons on the toolbar 
marked by  are available only in the SpaceMaker Plus® for Windows Enhanced Edition.

Button Action File Menu Equivalent

List duplicate files on the disk List Duplicates

 
List largest files on the disk List Largest

 
List oldest files on the disk List Oldest

 
List newest files on the disk
List Newest

 
List files by pathnames 
List by Pathname

List files by names List by Name

Print the view window Print...

Display current disk characteristics Disk Info...

Button Action Edit Menu Equivalent

Delete selected files Delete

Find and select files in the list Find and Select

Select or deselect all listed files Select All

 Hide or show files in the list Hide Unselected



Edit Menu
The Edit menu provides commands to copy the file list from the Browse Window to Clipboard, select files 
for deletion, show and hide unselected files, search specific files in the list, and delete files from disk.

Delete Delete selected files from the drive.

Find and Select Find and select specified files in the Browse Window.

Hide Unselected Hide or show all files in the Browse Window.

Select All Select or deselect all listed files.

Select Select or deselect a single file in the Browse Window.

Cleanup List Remove identical entries from the Browse Window.  

Copy Copy selected text to the clipboard.



Options Menu
The Options menu provides commands for customizing the Browse Window. You can change character 
font and size used to display information in the window, change letter case, and disable or enable output 
fields.

Font Execute font dialog box

Show Size Show or hide file size fields

Show Date Show or hide file date fields

Show Time Show or hide file time fields

Show Attributes Show or hide file attributes fields

Show Path Show or hide file location

Lowercase Display list of files in lowercase or uppercase.



File Menu
The File menu provides commands for searching and listing specific files, printing and exiting the 
application.

List Duplicates List all duplicate files.

List Largest List largest files. 

List Oldest List oldest files. 

List Newest List newest files. 
 

List by Name List files in the alphabetical order.

List by Pathname List files by pathnames. 
 

Disk Info Display information about the current drive.

Print Print the list of files.

Print Setup Set printer characteristics.

Execute File Execute file in the Browse Window.

Exit Exit SpaceMaker for Windows.



Printing
There are two commands on the File menu which support printing. The Print     Setup   command under the 
File menu allows you to select and configure your printer device.    Print command under the File menu 
allows you to print the current contents of the Browse Window. Note that you can print only visible fields. 
You can show or hide fields from the Options Menu.



Copying Text
To copy the list of files from the Browse Window to clipboard choose the Copy command under the Edit 
menu.



Deleting Files
To delete a file or files from the Browse Window, mark the files you want to delete by clicking a left mouse
button or pressing Enter key for each file, and do one of the following:

choose the Delete command under the File menu,

press Del key on the keyboard, or 

click on the  button in the toolbar.



Exiting
To exit the application, choose Exit command under the File menu. You can also press Alt-F4 key 
combination to exit any Windows application.



Browse Window
The Browse Window in this application is where you can browse the list of files. You can choose 
commands by selecting any one of the active buttons from the Toolbar or the menu. You can also use 
mouse to perform additional actions.

Mouse action Event
Left button single click Select or deselect a file in the list

Left button double click Execute highlighted program or document. 

Drag and drop Dragging and dropping files from the Program Manager into the Browse 
Window. The existing list of files will be cleared just before dropping new 
files. To append new files to the existing list use the drag and drop 
feature while holding down the Ctrl key.

The status bar at the bottom of the screen displays context sensitive messages, indicates current search 
option used and shows the line number of the file in focus.



Drag & Drop from the File Manager 
Directories and files can be dragged from the File Manager and dropped into the applications Browse 
Window. Make sure that you start dragging them from the right panel of the File Manager. You can tell 
whether you are able to drop files or directories into the program by looking at the cursors shape. The 
cursor should look like a document symbol with a plus sign inside it. 

Dragging new items from the File Manager replaces contents of the Browse Window. If you want to 
append items to the existing list, hold down the Ctrl key while dropping them into the Browse Window

Hint: You can use the above append feature to list files and directories from different drives at once. Just 
select desired items from any drive you want and append them to the existing list. Repeat that procedure 
for any directory or disk drive you wish to include in the list.



Output Fields
The information displayed in the Browse Window is composed of output fields. There are six types of 
field: Filename, Size, Date, Time, Attr and Path. All fields except the Filename field can be shown or 
hidden from the Options Menu. The Filename field is always visible and cannot be removed from the 
screen.

Note that disabled or hidden fields will not be sent to a printer.



Lowercase Command
The Lowercase command under the Options menu toggles Browse Windows display between lowercase 
and uppercase letters. 



Show Size Command
The Show Size command under the Options menu displays or hides the Size field. Hidden fields are 
removed from the screen and will not be sent to the printer.



Show Date Command
The Show Date command under the Options menu displays or hides the Date field. Hidden fields are 
removed from the screen and will not be sent to the printer.



Show Time Command
The Show Time command under the Options menu displays or hides the Time field. Hidden fields are 
removed from the screen and will not be sent to the printer.



Show Attributes Command
The Show Attributes command under the Options menu displays or hides the Attributes field. Hidden 
fields are removed from the screen and will not be sent to the printer.



Show Path Command
The Show Path command under the Options menu displays or hides the Path field. Hidden fields are 
removed from the screen and will not be sent to the printer.



Font Command
The Font command under the Options menu executes the Windows Font dialog box. It allows you to 
customize font type and size that is used to display information in the Browse Window. Font attributes 
such as italics and bold can also be changed. 

Note: changes to the current font will not affect printing. Printing is currently supported with a default fixed 
pitch printer font.



 Hide Unselected Command
The Hide Unselected command under the Edit menu hides all not currently selected files in the Browse 
Window. If there are files already hidden by this command choosing this menu item will make them visible
again. This feature is very handy in managing larger selections of files.



Copy Command
The Copy command under the Edit menu copies the list of files from the Browse Window into the 
clipboard. Later, you can paste the copied information into another application by selecting the Paste 
command under the Edit menu of that application. If the copied list looks misaligned in the clipboard, 
change the font to a fixed width font by selecting the OEM Text command under the Display menu.



Cleanup List Command  

The Cleanup List command under the Edit menu removes identical entries in the Browse Window . It 
does not remove files from the disk drive. This feature is useful when some entries were duplicated while 
appending files using the drag and drop feature. By default, the program does not compare dropped files 
with what it already has in the Browse Window since it slows down the operation. Therefore, this feature 
is left for the user to activate.

Note: this option is enabled only when the Browse Window contains files appended by using drag and 
drop feature.



Execute File Command
The Execute File command under the File menu executes the file in focus. The alternative would be to 
double click on the line with the left mouse button. If the file is a document, the program associated with it 
will be launched automatically.



A line in the Browse Window is in focus if it is surrounded by a dotted rectangle. Note, that the line itself 
does not have to be selected or highlighted to be in focus.



Exit Command
The Exit command under the File menu exits SpaceMaker for Windows. The program will terminate 
immediately.



Duplicate files are files that have the same name and the same extension but are located in different 
directories. They can have different lengths and creation dates.



 List Duplicates Command
The List Duplicate command under the File menu scans selected drive for duplicate files and lists them in 
the Browse Window. The search starts from the directory chosen in the open file dialog box and continues
until all its subdirectories are processed.

See also: Reclaiming Disk Space



 List Largest Command 

The List Largest command under the File menu scans selected drive for the largest files and lists them in 
the Browse Window. The search starts from the directory chosen in the open file dialog box and continues
until all its subdirectories are scanned.

See also: Reclaiming Disk Space



 List Oldest Command 

The List Oldest command under the File menu scans selected drive for the oldest files and lists them in 
the Browse Window. The search starts from the directory chosen in the open file dialog box and continues
until all its subdirectories are scanned.

See also: Reclaiming Disk Space,    List Newest Command



 List Newest Command 
 

The List Newest command under the File menu scans selected drive for the newest files and lists them in 
the Browse Window. The search starts from the directory chosen in the open file dialog box and continues
until all its subdirectories are scanned.

See also: List Oldest Command



 List By Name Command
The List By Name command under the File menu scans selected drive for files and lists them 
alphabetically in the Browse Window. The search starts from the directory chosen in the open file dialog 
box and continues until all its subdirectories are scanned.



 List By Pathname Command 
 

The List By Pathname command under the File menu scans selected drive for files and lists them by 
pathnames in the Browse Window. The search starts from the directory chosen in the open file dialog box
and continues until all its subdirectories are scanned.



 Print Command
The Print command under the File menu prints the contents of the Browse Window. Use the Print Setup 
command under the File menu to select a printer, and to set printer options. You can choose to print entire
list or its subset . To print a subset of the list mark files you want to print before executing the print 
command. Later, in the printer dialog box choose Selection radio button as the print range rather then All 
radio button.



Print Setup Command
The Print Setup command under the File menu displays the Printer Setup dialog box which allows you to 
select and configure your printer.



 Delete Command
The Delete command under the Edit menu deletes all files currently selected in the Browse Window. 
Before the files are deleted you will be asked for confirmation. You can choose to delete a single file, 
delete all selected files, skip a file, or cancel the procedure. 

Caution: selecting delete all in the dialog box will delete all remaining files without further confirmations. 
However,    if a selected file is a system, hidden, or read-only file you still will be asked to confirm the 
deletion. Also, make sure that all files that you wish to delete are not used at the same time by other 
applications.

See also: Reclaiming Disk Space



Select Command
The Select command under the Edit menu selects or deselects a file in the Browse Window. Selected 
files can be later deleted from the disk by choosing the Delete command or sent to the printer.

See also: Select all Command, Print Command



 Select All Command
The Select All command under the Edit menu toggles selection of all files in the Browse Window. If one or
more files are already selected in the list the command deselects them. If no files are selected, the 
command selects entire list. 

See also: Select Command



 Find and Select Command
The Find and Select command under the Edit menu searches the list of files in the Browse Window for 
files matching user supplied pattern. The search compares compares filenames only. As each match is 
found, it is highlighted in the list. The filenames may contain standard DOS wild card characters such as ?
and *. Please refer to your DOS reference manual for rules governing usage of wild card characters.



 Disk Info Command
Selecting the Disk Info command under the File menu displays information about the current drive, such 
as a total disk space, amount of free memory and the size of the disk allocation unit.



Disk allocation unit
Disk allocation unit is the least amount of disk space that can be allocated by a file. Files can be of any 
size but they are stored on disk in the series of clusters of equal size. Depending on the type of the drive, 
the disk allocation unit can have different lengths. For example, a floppy drive allocation unit usually has 
512 bytes and hard drives units start from 2048 bytes and go up to 8192 bytes and more. Even though 
your file contains only a single character it will use disk space equal to at least one allocation unit.



Reclaiming disk space
The Murphys Law says that the larger the disk drive the faster it will fill up. And as the result you may 
quickly end up with the hard drive almost completely full. If you have come across errors such as 
Insufficient disk space or Destination disk full when attempting to write to a disk drive you know the 
problem first hand. But do not worry, the situation need not necessarily force you to buy a new, larger 
hard drive. Here are some hints on how to manage your disk space and, at the same time, save your 
money:

Delete old files that are no longer in use

Delete large files you do not need

Delete duplicate files

Combine small files into one larger file

Delete backup and temporary files

See also: SpaceMaker Plus,    List Duplicates,  List Largest,    List Oldest,    List Newest



Delete backup and temporary files
Almost every application creates backup copies of files or documents you have modified. Although this 
safety mechanism allows you to restore original data after you have made changes, it also effectively 
reduces the disk space available for other programs. Sometimes you do not need this extra protection. 
You can then remove those backup files still leaving original copies on the disk. Good candidates for 
deletion here are files with extensions such as bak,    bk!,    ~*.

See also:    List Duplicates,    List Largest,    List Oldest,    Combine Small Files



Combine small files into one larger file. 
Each file stored on the disk occupies at least one disk allocation unit of disk space. The unit size is related
to the capacity of the drive itself. The larger the drive the larger the unit size. For example, if the unit size 
is 4kB it means that 4kB is the smallest space that can be allocated to one file. Eliminating small files or 
combining them into a larger one may therefore save you thousands of bytes of disk space. 

See also:    List Duplicates,    List Largest,    List Oldest,    Delete Backup and Temporary Files



Delete old files that are no longer in use.
If you have executable files (those with EXE or COM extensions) from 1987 or so, there is a chance you 
dont really need them. By now you either have newer versions of these programs, or they are simply 
obsolete. These executables tend to be large so the disk space savings can be significant. Be careful 
though not to delete files you do use or those required by other programs. When in doubt - keep them.

See also: SpaceMaker Plus,    List Oldest,    List Newest



Delete large files you do not need. 
Your hard drive may easily become a collection of large and very large files. And you might not be even 
aware of that. They can easily tie up many megabytes of precious disk space! These files are listings 
produced by parsers and capture programs, bitmaps, sound waves, and symbolic tables just to name a 
few. Some of them are created automatically by your applications without your knowledge. Delete them - 
chances are you wont be using them anyway. Be careful though not to delete files you might need!

See also: SpaceMaker Plus,    List Largest



Delete duplicate files. 
It is amazing how many files are duplicated. You can have the same libraries, executables, configuration 
and initialization files. You may also have different versions of the same utility programs, documents, 
games... The list goes on, and on. Most of the time you need only one copy of the file.

There is a simple rule of thumb which of the two files should be deleted: pick a much older copy or if the 
dates are not too distant, choose a smaller one. If in doubt - examine them to verify the contents or 
compare version numbers.

See also: SpaceMaker Plus,    List Duplicates



File Search Dialog Box
This dialog box is where you specify names of files you wish to find and where you change a starting 
search directory.

File name
The File Name input box is where you enter the name or name pattern of files to search. You can use 
standard DOS wildcards: ? and *. If you enter a file name with a wildcard and press Enter, you will see a 
list of all matching files in the file list box below.

Example: 
*.exe - search for executable files with an EXE extension
*.* - search for any file
README.TXT - search for README.TXT files

List Files of Type
In this list box you can select the predefined file name pattern to search. If new file pattern is selected the 
changes will be reflected in the File name input box.

Directories
The Directories list box displays directories on currently selected drive. Double-click a directory name or 
icon to switch to a new directory. Use this list box to choose a directory you want the file search to start 
from. All subdirectories of the selected directory will also be scanned. For example, selecting c:\ (root 
directory) will search the entire C: drive.

Drives
This list box is where you select a new search disk drive.

See also: List Duplicates,    List Largest,    List Oldest,    List in Alphabetical Order



SpaceMaker® Standard Edition
The Standard Edition of the SpaceMaker for Windows is a fully functional and powerful duplicate file 
search utility. It is available from most ftp sites on Internet as well as from many BBSs around the world. 
You can evaluate SpaceMaker Standard Edition for a period of 30 days but if you continue on using the 
program you must register. 

You can also order SpaceMaker Plus® Enhanced Edition for a small additional fee at the time of 
registration. Please see How to Register for more information.

Main features of the Standard Edition include searching for duplicate files on any disk, searching and 
listing files in alphabetical order, deleting or executing selected files, and more.

See also: Enhanced Edition



SpaceMaker Plus® Enhanced Edition 
The Enhanced Edition of the SpaceMaker for Windows is available only to registered users. Please see 
How to Register for more information. In addition to the Standard Edition features, the Enhanced Edition 
contains many new capabilities and improvements. They are marked with a  symbol throughout the 
help file.

Features added to SpaceMaker Plus:
- Listing largest files on any disk, 

- Listing oldest files on any disk, 

- Listing newest files on any disk, 

- Combining file lists from multiple disk drives using drag and drop feature,
- Easy switching between different views: duplicates, largest, oldest, and newest files , files 
sorted by name as well as pathname 

- Drag and drop capabilities,
- And more . . .
See also: duplicate files



If you have a printer you can print the order form by selecting Print Topic command under the File menu in
this help file.



How to Register SpaceMaker
If you use SpaceMaker for Windows (Standard Edition) for over 30 days you must register the program. 
Upon registration you will receive the latest version of the utility and you will be eligible for upgrades at 
lower prices. Please, send registration form (you can print this form) and a money order or certified 
check drawn on any Canadian or US bank to:

Copernicus Software International
Box 2354, 349 W. Georgia Street

Vancouver, B.C., Canada, V6B 3W5

Personal checks will be accepted but the shipment can be delayed due to slow inter-bank fund transfers. 
If you have any comments or questions please fax us at (604) 669-9766.
Please note that registered users can upgrade to SpaceMaker Plus (Enhanced Edition) for only US$5.95
a copy!

 SPECIAL CHRISTMAS 1994 PRICING!     

If you order SpaceMaker Plus before December 31, 1994 you will receive 20% off the regular price. 
Please hurry if you want to have your order shipped before the holiday season!

Name: _________________________________ Phone:
__________________________________
Company: _______________________________________________________________________
Address: ________________________________________________________________________
City: ___________________________________ State/Prov:
_______________________________
Country: ________________________________ Zip/Post Code:
___________________________
Electronic mail address: ___________________ Computer type:___________________________
Where did you hear about the SpaceMaker? ___________________________________________
Any comments and suggestions will be appreciated ______________________________________

SpaceMaker copies ordered: ______ x US$15.95 (Can$19.95) per copy  = _________
Upgrade to SpaceMaker Plus add ______ x US$5.95 (Can$7.95) per copy  = _________

or Upgrade to the latest version: ______ x US$2.95 (Can$3.95) per copy  = _________
(for registered users only)
Site License:
10 to 50 computers: ______ x US$11.95 (Can$14.95) per comp  = _________
more then 50 computers: ______ x US$9.95 (Can$12.95) per comp  = _________
Upgrade to SpaceMaker Plus add ______ x US$3.95 (Can$4.95) per comp  = _________

Subtotal     _________
less 20% (Christmas offer only)     _________

Subtotal     _________
Canadian residents add 7% GST = _________

B.C. residents add 7% PST = _________
Shipping & Handling ($3.00 US & Canada, $5.00 overseas) = _________

Floppy disk requested: __ 3½        __5¼ Total     _________



Windows Keys
Cursor Movement Keys
Dialog Box Keys
Editing Keys
Help Keys
Menu Keys
System Keys
Text Selection Keys
Window Keys



Cursor Movement Keys

Key(s) Function

Arrow key Moves the cursor left, right, up, or down in a field.
End or Ctrl+Right Arrow Moves to the end of a field.
Home or Ctrl+Left Arrow Moves to the beginning of a field.
Pape Up or Page Down Moves up or down in a field, one screen at a time.



Dialog Box Keys

Key(s) Function

Tab Moves from field to field (left to right and top to bottom).
Shift+Tab Moves from field to field in reverse order.
Alt+letter Moves to the option or group whose underlined letter matches 

the one you type.
Arrow key Moves from option to option within a group of options.
Enter Executes a command button.

Or, chooses the selected item in a list box and executes the 
command.

Esc Closes a dialog box without completing the command. (Same as
Cancel)

Alt+Down Arrow Opens a drop-down list box.
Alt+Up or Down Arrow Selects item in a drop-down list box.
Spacebar Cancels a selection in a list box.

Selects or clears a check box.
Ctrl+Slash Selects all the items in a list box.
Ctrl+Backslash Cancels all selections except the current selection.
Shift+ Arrow key Extends selection in a text box.
Shift+ Home Extends selection to first character in a text box.
Shift+ End Extends selection to last character in a text box



Editing Keys

Key(s) Function

Backspace Deletes the character to the left of the cursor.
Or, deletes selected text.

Delete Deletes the character to the right of the cursor.
Or, deletes selected text.



Help Keys

Key(s) Function

F1 Gets Help and displays the Help Index for the application. If the 
Help window is already open, pressing F1 displays the "Using 
Windows Help" topics.
In some Windows applications, pressing F1 displays a Help topic
on the selected command, dialog box option, or system 
message.

Shift+F1 Changes the pointer to  so you can get Help on a specific 
command, screen region, or key. You can then choose a 
command, click the screen region, or press a key or key 
combination you want to know more about.

(This feature is not available in all Windows applications.)



Menu Keys

Key(s) Function

Alt Selects the first menu on the menu bar.
Letter key Chooses the menu, or menu item, whose underlined letter 

matches the one you type, when a menu has focus.
Alt+Letter key Pulls down the menu whose underlined letter matches the one 

you type.
Left or Right Arrow Moves among menus of the main menu bar.
Up or Down Arrow Moves among menu items within a drop-down menu.
Enter Chooses the selected menu item.



System Keys

The following keys can be used from any window, regardless of the application you are 
using.

Key(s) Function

Ctrl+Esc Switches to the Task List.
Alt+Esc Switches to the next application window or minimized icon, 

including full-screen programs.
Alt+Tab Switches to the next application window, restoring applications 

that are running as icons.
Alt+PrtSc Copies the entire screen to Clipboard.
Ctrl+F4 Closes the active window.
F1 Gets Help and displays the Help Index for the application. (See 

Help Keys)



Text Selection Keys

Key(s) Function

Shift+Left or Right Arrow Selects text one character at a time to the left 
or right.

Shift+Down or Up Selects one line of text up or down.
Shift+End Selects text to the end of the line.
Shift+Home Selects text to the beginning of the line.
Shift+Page Down Selects text down one window.

Or, cancels the selection if the next window is 
already selected.

Shift+Page Up Selects text up one window.
Or, cancels the selection if the previous 
window is already selected.

Ctrl+Shift+Left or Right Arrow Selects text to the next or previous word.
Ctrl+Shift+Up or Down Arrow Selects text to the beginning (Up Arrow) or end

(Down Arrow) of the paragraph.
Ctrl+Shift+End Selects text to the end of the document.
Ctrl+Shift+Home Selects text to the beginning of the document.



Window Keys

Key(s) Function

Alt+Spacebar Opens the Control menu for an application window.
Alt+Hyphen Opens the Control menu for a document window.
Alt+F4 Closes a window.
Alt+Esc Switches to the next application window or minimized icon, 

including full-screen programs.
Alt+Tab Switches to the next application window, restoring applications 

that are running as icons.
Alt+Enter Switches a non-Windows application between running in a 

window and running full screen.
Arrow key Moves a window when you have chosen Move from the Control 

menu.
Or, changes the size of a window when you have chosen Size 
from the Control menu.






